Metro-SCSM-100

SCSM Webportal Installation und Problembehebung

Für eine vollständige Demo- und Präsentationsumgebung benötigte ich kürzlich für meinen SCSM 2012 R2 noch einen SCSM Portal Server. Die SCSM 2012 R2 Portal Server Komponente benötigt zwingend einen SharePoint 2010 Anteil. SharePoint 2013 wird noch nicht offiziell von Microsoft unterstützt.
Um eine möglichst homogene Gesamt-Umgebung zu haben, war für mich klar, dass ich einen neuen Windows Server 2012 R2 als Basis für den SCSM 2012 R2 Portal Server verwenden wollte.
Nach Installation des Windows Server 2012 R2 Standard und Aufnahme des Servers in die Domäne, wird vor der SCSM 2012 R2 Webportal-Komponenten Installation ein SharePoint Server benötigt.
Für meinen Zweck benötige ich keine hochkomplizierte SharePoint Farm, sondern einfach nur den Ort, in dem mein System Center Service Manager 2012 R2 seine Webparts für das Webportal einbinden kann. Entsprechend entschied ich mich für den SharePoint 2010 Foundation Server inkl. SP2 (Erst ab SP wird der Windows Server 2012 R2 offiziell unterstützt).

SharePoint 2010 Foundation inkl. SP2 Download: http://www.microsoft.com/de-de/download/details.aspx?id=24983
Die Installation zu eigenen Dokumentationszwecken wieder möglichst vollständig, auch wenn die Installation zunächst mal recht schnörkellos läuft.

Die Installation der SharePoint Foundation 2010 SP2 Voraussetzungen

Ich habe vor der Installation keinerlei manueller Anpassungen am OS getätigt. Keine IIS Rolle oder ähnliches installiert oder konfiguriert.





Während der Installation der Vorbereitungstools sollte eine Internetverbindung bestehen, sodass Komponenten automatisch heruntergeladen und installiert werden können. Ansonsten erhöht sich der manuelle Aufwand entsprechend. In diesem Test-Szenario ist mir aber vor allem daran gelegen, dass ich mich mit dem SharePoint Anteil nicht allzu lange aufhalten muss.


In meinem Fall musste die Installationsdatei mit erhöhten Rechten ausgeführt werden. Die Installation der Vorbereitungstools musste ich 2 oder 3 mal ausführen bis alle Voraussetzungen installiert waren.

Installation des SharePoint 2010 Foundation inkl. SP2


Auswahl: Eigenständig – für mein Test-Szenario genau das was ich brauche.
Anschließend läuft die Installation los:




Ich habe das beenden bzw. Neustarten der SharePoint-Dienste erlaubt und schon läuft die Konfiguration selbständig los.


Im Anschluss kann ich dann das angehen, was mich eigentlich interessiert. Nämlich an die Installation des SCSM 2012 R2 Web Portals.

Die SCSM Service Manager-Webportal Installation

Zu Doku-Zwecken wieder eine recht vollständige Screenshot-Schlacht:




Das erste Problem: SharePoint Sprachpaket Konfusion

Es gab bei der Voraussetzungsprüfung eine Fehlermeldung:

Der direkte Link für das SharePoint 2010 Foundation Sprachpaket: http://www.microsoft.com/de-de/download/details.aspx?displaylang=en&id=4731

Wichtig ist auch das SP2 für das Sprachpaket! http://www.microsoft.com/de-de/download/details.aspx?id=39674, in meinem Fall war das aber bereits installiert.

Verrückterweise wird hier von dem deutschen Sprachenpaket gesprochen das auf meinem deutschen SharePoint Server benötigt wird. Erst die Installation des ENGLISCHEN Sprachenpaketes wurde von dieser Voraussetzungsprüfung akzeptiert. Ich hatte in meinem Fall nun das deutsche und das englische Sprachenpaket auf dem System parallel nebeneinander installiert.
Erst danach lässt sich das SCSM 2012 R2 Web-Portal installieren.

Zu der Speichermeldung schweige ich! :)

Um den Aufwand möglichst gering zu halten, habe ich in der IIS Konsole ein selbstsigniertes Zertifikat erstellt, welches ich dann hier auswählen kann:


Das selbstsignierte Zertifikat hat mich dann aber schnell gestört, sodass ich das selbstsignierte Zertifikat recht schnell nach der Installation durch eines von meiner zweistufigen PKI in meiner Testumgebung ersetzt habe. Für die ersten Funktionstests tut es aber das selbstsignierte ganz hervorragend.


Hier habe ich extra für den Datenbankzugriff für das Web-Portal einen entsprechenden Service-Account angelegt:


Hier verwende ich den eben erstellten Service-Account erneut, irgendwo hört der Spaß für eine Testumgebung auf :)




Die Grundinstallation ist verhältnismäßig geschmeidig durchgelaufen. Es gab aber einige Probleme die noch behoben werden mussten. Dazu im Folgenden mehr.

Leeres SCSM Portal durch fehlenden FQDN im IIS


Einer der Fehler der an dieser Stelle am häufigsten vor kommt und ein leeres Portal verursacht, ist eine Fehlkonfiguration bezüglich des FQDN im IIS. Im IIS Manager des Web Servers wird unter „Sites | Service Manager Portal | Anwendungseinstellungen“ der Fully Qualified Domain Name benötigt.


Webserver Stoppen, Neustarten, im Client den Browser-Cache leeren und die Sache sieht deutlich besser aus:

Leeres SCSM Portal nach Zertifikat-Austausch

Ich hatte den Fehler eines leeren SMPortals später aber nochmal. Nämlich nach dem späteren Austausch des selbstsignierten Zertifikates gegen das meiner PKI. Das neue SSL Zertifikat muss im IIS an zwei Stellen für die Bindung der https Verbindung eingestellt und verwendet werden:

  1. Unter „Sites | Management Portal“
  2. Unter „Sites | SCSMWebContentServer

Danach gab es wieder klare Sicht auf die Inhalte.

Zugriff auf das Portal als Standard-Benutzer: Access Denied

Als normaler Benutzer bekomme ich beim Zugriff auf das SCSM Web Portal leider noch ein Access Denied um die Ohren:

Um diesen Zustand zu verändern, habe ich mich erneut als Administrator auf meinem SMPortal angemeldet und unter „Site Actions | Site Permissions | Grant Permission“ der Active Directory Gruppe „Domänen-Benutzer“ das Recht „Lesen“ eingeräumt. In der Gesamtansicht sehen die Rechte dann so aus:


Anschließend kommen die Domänen-Benutzer ebenfalls an das SCSM SharePoint Portal heran. Dort können sie dann im Web-Frontend neue Service Requests erstellen oder neue Incidents erstellen.

Manuelle Authentifizierung bei Anmeldung am SCSM Web Portal

Der nächste nervige Punkt ist der, dass man beim Zugriff auf das SMPortal immer seine Anmeldeinformationen eingeben muss. Sogar zwei Mal:

Das Problem kann behoben werden, indem die URL des SCSM WebPortals in die Liste der Seiten des lokalen Intranets im Internet Explorer aufgenommen wird. Durch die Konfiguration im Internet Explorer verschwindet in meinem Fall auch die Notwendigkeit der Authentifikation im Opera Browser.

Zugriff auf die SharePoint Settings des SCSM Web Portals

Der Zugriff auf die Sharepoint Einstellungen des SCSM Web Portals endete leider immer mit einer Fehlermeldung: Error, File Not Found. Troubleshoot issues with Microsoft SharePoint Foundation.
Correlation ID: cf461cce-7f0c-4e81-80cb-c36435579ed4


Auch dieses Problem ließ sich beheben. Der Weg zur Lösung führt über die Central Administration Site des SharePoint Servers. Dort fiel mir sofort im Bereich „Alternative Zugriffszuordnungssammlung auswählen“ auf, dass dort keine FQDN verwendet wurden. Nach Ändern der Werte in FQDN, waren auch die SharePoint Einstellungen des SCSM Portals sauber zu erreichen:

Ändern der Überschrift SMPortal

Den Text der Überschrift kann man über folgendem Weg ändern: „Site Actions | Site Settings | Title, Description and Icon“.

Ändern des Themes bzw. der Farbgestaltung

Die Optik kann man über folgendem Weg ändern: „Site Actions | Site Settings | Site theme“

Spracheinstellungen im SCSM Web Portal

Was mich dann noch störte, naja nicht wirklich, war die englische Sprache im Portal. Ich hatte mich ja durchaus bewusst für die deutsche Version in meiner Testumgebung entscheiden. Unter „Site Actions | Site Settings | Language Settings“ konnte ich auf Deutsch wechseln:
Eine Beschreibung dazu ist auch hier zu finden: http://technet.microsoft.com/en-us/library/hh916542.aspx
Die Link-Überschriften „Help Articles, My Requests, My Activities“ müssen manuell übersetzt werden. Die Möglichkeit dazu gibt es unter „Site Actions | Site Settings | Quick Settings“

Damit ist für mich die Basiskonfiguration erstmal abgeschlossen und hier eine letzte Gesamtübersicht:

VN:F [1.9.22_1171]
Beitrag bitte hier bewerten:
Rating: 5.0/5 (1 vote cast)
SCSM Webportal Installation und Problembehebung, 5.0 out of 5 based on 1 rating

3 Gedanken zu „SCSM Webportal Installation und Problembehebung“

  1. Hallo,
    ich scheitere immer am Softwarestand des SQL Express: Der Vorwurf beim Verbinden mit der Sharepoint-Datenbank lautet, dass ich nur SQL 2008 verwende Updates schlagen aber mit dem Fehler Cross Language Update not supportet fehl.
    Server 2012 R2 Std EN (VM auf Hyper-V)
    Sharepoint Foundation SP2 DE
    Der Rest ist „out of the Box“

    So langsam gehen mir die Ideen aus

    1. Gefunden und gelöst: Die zweite Datenbankverbindung muss die zum SCSM Server sein. Der Sharepoint schlägt sich aber selbst vor. Mit der korrekten Datenbank klapp dann acuh alles…

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.